One of the tasks
developers have is adding a test when making code change. That is just good engineering practice - you
always want to make sure your code works, and then when I make a change, I want
to test that I did not break your code.
It's pretty self-explanatory, really.
The trick here is
that when someone fixes a bug report.
Bug reports are tracked by number, so I may be working on bug 1234
today. When I get a fix in place, I need
to add a test. Now, when I add the test,
I need to give the test a name.
One easy way to name
the test is naming it after the bug number being fixed, like this:
Test_Bug1234()
That makes it
possible for anyone else that needs to look at this code to know to check the
bug database for details around bug 1234.
I chose the word "possible" there specifically because while
it is possible to do this, it is time consuming. I have to switch from my IDE (I use Visual
Studio) to the bug tool and dig up the bug report.
Now imagine if I had
named that test this instead:
Test_AddNewFrenchRegionsToMaps()
Now if I am reading
that code, or investigating a failure, I have a MUCH better starting
point. I know that the test I
potentially broke had to with French regions and maps. If I am changing map code, I am very
interested in what I might have broken and know where to start my investigation
much more quickly. I don't have to
switch out of my IDE to get this data and it saves me a little bit of time
overall.
So while I am going
through tests, I am not renaming the old format with a bit of descriptive
text. The next challenge I might take on
is trying to quantify how much time I am saving overall.
Questions, comments,
concerns and criticisms always welcome,
John
No comments:
Post a Comment